KDE 4.8 – openSUSE 12.1

KDE 4.8 baru saja dirilis tanggal 25 Januari 2012 kemarin. Sampai saat ini saya masih memakai KDE 4.8 RC 2 di mesin Arch Linux, KDE 4.7.4 di mesin Chakra Linux dan KDE 4.7.2 di mesin openSUSE 12.1. Berhubung paket KDE 4.8 masih berada di repo [testing] untuk Arch Linux dan di repo [kde-unstable] untuk Chakra Linux maka upgrade KDE 4.8 saya pending dulu, menunggu paket KDE tersebut masuk ke [extra] (Arch Linux) dan [desktop] (Chakra Linux). Sekalian buat bahan acara pesta rilis KDE malam minggu besok tersenyum lebar

Nah! Karena di openSUSE sudah ada paket KDE 4.8 (walaupun tidak ada di repo resmi) saya tergoda untuk upgrade KDE dari 4.7.2 ke KDE 4.8. Godaan untuk mengupgrade KDE ke 4.8 semakin kuat gara-gara pak Willy dan om Widya Walesa wajah tanpa emosi

Woke… saatnya setup repository KDE Release di openSUSE 12.1. Cukup mudah untuk memasang repository KDE 4.8 di openSUSE 12.1 ini. Hal yang perlu saya lakukan adalah menambahkan repository KDE menggunakan zypper dan mengupgrade melalui repository tersebut:

sudo zypper ar http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1/ KDE-4.8
sudo zypper mr -r KDE-4.8
sudo zypper dup --from KDE-4.8

Di mesin saya, ada masalah pada saat upgrade KDE 4.8, yaitu:

Loading repository data...
Reading installed packages...
Computing distribution upgrade...
3 Problems:
Problem: k3b-codecs-2.0.2-13.19.x86_64 requires k3b = 2.0.2-13.19, but this requirement cannot be provided
Problem: qt4-qtscript-0.1.0-14.1.2.x86_64 requires libqt4 = 4.7.4, but this requirement cannot be provided
Problem: kdm-4.8.0-723.3.x86_64 requires kdm-branding = 4.8.0, but this requirement cannot be provided
Problem: k3b-codecs-2.0.2-13.19.x86_64 requires k3b = 2.0.2-13.19, but this requirement cannot be provided
 Solution 1: deinstallation of k3b-codecs-2.0.2-13.19.x86_64
 Solution 2: keep obsolete k3b-2.0.2-13.19.x86_64
 Solution 3: keep obsolete k3b-2.0.2-13.19.x86_64
 Solution 4: break k3b-codecs by ignoring some of its dependencies

Solusinya cukup memilih pilihan pertama. Namun nanti akan ada masalah lagi, akan tetapi itu tidak jadi soal:

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c): 1
Problem: qt4-qtscript-0.1.0-14.1.2.x86_64 requires libqt4 = 4.7.4, but this requirement cannot be provided
 uninstallable providers: libqt4-4.7.4-19.2.2.i586[openSUSE Current OSS]
 libqt4-4.7.4-19.2.2.x86_64[openSUSE Current OSS]
 Solution 1: Following actions will be done:
 keep obsolete libqt4-4.7.4-19.4.1.x86_64
 keep obsolete kdegames4-carddecks-default-4.7.2-3.1.2.noarch
 keep obsolete libkdeedu4-data-4.7.2-2.1.2.noarch
 Solution 2: deinstallation of qt4-qtscript-0.1.0-14.1.2.x86_64
 Solution 3: keep obsolete libqt4-4.7.4-19.4.1.x86_64
 Solution 4: break qt4-qtscript by ignoring some of its dependencies
Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c): 2
Problem: kdm-4.8.0-723.3.x86_64 requires kdm-branding = 4.8.0, but this requirement cannot be provided
 uninstallable providers: kdm-branding-upstream-4.8.0-723.3.i586[KDE-4.8]
 kdm-branding-upstream-4.8.0-723.3.x86_64[KDE-4.8]
 kdm-branding-basedonopensuse-12.1-6.1.2.i586[openSUSE Current OSS]
 kdm-branding-basedonopensuse-12.1-6.1.2.x86_64[openSUSE Current OSS]
 Solution 1: deinstallation of kdm-4.7.2-6.4.1.x86_64
 Solution 2: deinstallation of kdm-branding-openSUSE-12.1-15.3.9.noarch
 Solution 3: keep obsolete kdm-4.7.2-6.4.1.x86_64
 Solution 4: keep obsolete kdm-4.7.2-6.4.1.x86_64
 Solution 5: keep obsolete kdm-4.7.2-6.4.1.x86_64
 Solution 6: break kdm by ignoring some of its dependencies
Choose from above solutions by number or skip, retry or cancel [1/2/3/4/5/6/s/r/c] (c): 2
Resolving dependencies...
Computing distribution upgrade...

Nah, beres kan? Sekarang tinggal melanjutkan saja. Sambil menunggu download paket KDE, lebih baik sekarang ngopi-ngopi dulu dan tentu saja sambil rokokan tersenyum lebar

Hurrayyy! Sekarang sudah memakai KDE 4.8, nggak kalah sama pak Willy dan om Widya Walesa tertawa

KDE 4.8 - openSUSE 12.1

KDE 4.8 - openSUSE 12.1

=-=-=-=-=
Powered by Blogilo

4 thoughts on “KDE 4.8 – openSUSE 12.1

  1. mas Go2n makin mantap saja nih.. masih ingat aku nggak mas? aku temennya Sisil yg dulu ikutan utak-atik laptopnya waktu mo pendadaran 😀
    gara2 tdk sengaja nemu blog sampeyan.. aku ikut2an upgrade kde 4.7.4 ke 4.8.1

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s