Hangout dengan Chakra

Diajakin bayek tabung hangout di Google+ jadi ingat kalau belum install google-talkplugin di Chakra. Sayangnya paket google-talkplugin hanya tersedia dalam bentuk .deb (Debian/Ubuntu) dan .rpm (Fedora/openSUSE).

Untung di Chakra ada tool ccr yang bisa buat install paket tersebut :D. Sip lah sekarang cari paket google-talk-plugin dulu lalu install (tentunya dengan ccr).

[go2n@chakra ~]$ ccr google-talkplugin
0 ccr/google-talkplugin 2.1.7.0-1
Video chat browser plug-in for Google Talk, needs lib32 repo enabled

Type numbers to install. Separate each number with a space.
Numbers: 0
Dependency `lib32-alsa-lib' of `google-talkplugin' does not exist.

Ternyata eh ternyata, google-talkplugin memerlukan pustaka 32 bit untuk bisa berjalan di mesin x86_64 toh? Alhasil instalasi google-talkplugin gagal gara-gara tidak menemukan pustaka 32bit di repository. Jika di Arch Linux repository untuk pustaka 32bit semua ada di [multilib], sedangkan di Chakra tidak ada repository [multilib]. Nah lho! Bagaimana bisa install google-talkplugin kalau dependensinya aja ga ada?

Setelah jalan-jalan di websitenya Chakra akhirnya ketemu juga repository yang memuat pustaka 32bit yaitu [lib32]. Sekarang tinggal daftarkan repository tersebut terus install google-talkplugin-nya. Untuk mendaftarkan repository cukup tambahkan baris berikut di /etc/pacman.conf:

[lib32]
Include = /etc/pacman.d/mirrorlist

Update database pacman:


[go2n@chakra ~]$ sudo pacman -Syu
:: Synchronizing package databases...
core is up to date
platform is up to date
desktop is up to date
apps is up to date
games is up to date
lib32                                                            22.8K   23.9K/s 00:00:01 [#####################################################] 100%
:: Starting full system upgrade...
local database is up to date

Install google-talkplugin dengan ccr:


[go2n@chakra ~]$ ccr -S google-talkplugin

Ccr Targets    (1): google-talkplugin
Pacman Targets (14): glew lib32-alsa-lib lib32-alsa-oss lib32-gcc-libs lib32-gdk-pixbuf2 lib32-glibc lib32-gtk2 lib32-libstdc++5 lib32-libx11 lib32-libxfixes lib32-libxt lib32-openssl lib32-zlib libpng12

Proceed with installation? [Y/n] Y
resolving dependencies...
looking for inter-conflicts...

Targets (52): glew-1.5.8-1  lib32-glibc-2.13-3  lib32-alsa-lib-1.0.24.1-2  lib32-alsa-oss-1.0.17-3  lib32-gcc-libs-4.5.3-3  lib32-pcre-8.11-2
lib32-zlib-1.2.5-3  lib32-expat-2.0.1-2  lib32-dbus-core-1.4.0-2  lib32-glib2-2.28.6-2  lib32-libpng-1.4.4-2  lib32-libjpeg-8.0.2-2
lib32-libtiff-3.9.4-2  lib32-libxdmcp-1.1.0-1  lib32-libxau-1.0.6-2  lib32-libxcb-1.7-2  lib32-libx11-1.4.3-1
lib32-gdk-pixbuf2-2.22.1-2  lib32-atk-1.32.0-3  lib32-libxrender-0.9.6-2  lib32-freetype2-2.4.3-2  lib32-fontconfig-2.8.0-2
lib32-pixman-0.22.2-1  lib32-cairo-1.10.2-2  lib32-libxft-2.2.0-2  lib32-pango-1.28.3-2  lib32-util-linux-ng-2.19-3
lib32-e2fsprogs-1.41.14-1  lib32-openssl-1.0.0.d-3  lib32-db-4.8.30-1  lib32-sqlite3-3.7.5-2  lib32-heimdal-1.3.3-2  lib32-ncurses-5.9-3
lib32-readline-6.2.001-3  lib32-libgpg-error-1.10-1  lib32-libgcrypt-1.4.6-2  lib32-gnutls-2.8.6-2  lib32-libcups-1.4.6-1
lib32-libxfixes-5.0-1  lib32-libxcursor-1.1.11-2  lib32-libxext-1.2.0-2  lib32-libxrandr-1.3.1-2  lib32-libxi-1.4.2-1
lib32-libxinerama-1.1.1-1  lib32-libxcomposite-0.4.3-2  lib32-libxdamage-1.1.3-2  lib32-gtk2-2.24.5-1  lib32-libstdc++5-3.3.6-2
lib32-libice-1.0.7-2  lib32-libsm-1.2.0-3  lib32-libxt-1.1.1-1  libpng12-1.2.43-1

Total Download Size:    16.08 MB
Total Installed Size:   77.24 MB

Proceed with installation? [Y/n] Y
......................................................................................

Edit google-talkplugin PKGBUILD with $EDITOR? [Y/n] n
==> Making package: google-talkplugin 2.1.7.0-1 (Tue Jul 26 11:19:03 WIT 2011)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Downloading google-talkplugin_current_amd64.deb...
--2011-07-26 11:19:03--  http://dl.google.com/linux/direct/google-talkplugin_current_amd64.deb
Resolving dl.google.com... 209.85.175.190, 209.85.175.93, 209.85.175.136, ...
Connecting to dl.google.com|209.85.175.190|:80... connected.
HTTP request sent, awaiting response... 206 Partial Content
Length: 7725788 (7.4M), 6829304 (6.5M) remaining [application/x-debian-package]
Saving to: “google-talkplugin_current_amd64.deb.part”

100%[++++==================================>] 7,725,788    312K/s   in 24s

2011-07-26 11:19:28 (276 KB/s) - “google-talkplugin_current_amd64.deb.part” saved [7725788/7725788]

==> Validating source files with md5sums...
google-talkplugin_current_amd64.deb ... Passed
==> Extracting Sources...
-> Extracting google-talkplugin_current_amd64.deb with bsdtar
==> Entering fakeroot environment...
==> Starting build()...
==> Extracting...
x - debian-binary
x - control.tar.gz
x - data.tar.gz
./
./etc/
./etc/cron.daily/
./usr/
./usr/share/
./usr/share/doc/
./usr/share/doc/google-talkplugin/
./usr/share/doc/google-talkplugin/changelog.Debian.gz
./usr/lib/
./usr/lib/xulrunner/
./usr/lib/xulrunner/plugins/
./usr/lib/mozilla/
./usr/lib/mozilla/plugins/
./usr/lib/iceape/
./usr/lib/iceape/plugins/
./usr/lib/xulrunner-addons/
./usr/lib/xulrunner-addons/plugins/
./usr/lib/iceweasel/
./usr/lib/iceweasel/plugins/
./usr/lib/firefox/
./usr/lib/firefox/plugins/
./usr/lib/midbrowser/
./usr/lib/midbrowser/plugins/
./opt/
./opt/google/
./opt/google/talkplugin/
./opt/google/talkplugin/openssl.txt
./opt/google/talkplugin/cron/
./opt/google/talkplugin/cron/google-talkplugin
./opt/google/talkplugin/lib/
./opt/google/talkplugin/lib/libCg.so
./opt/google/talkplugin/lib/libCgGL.so
./opt/google/talkplugin/windowpicker.glade
./opt/google/talkplugin/GoogleTalkPlugin
./opt/google/talkplugin/libnpgtpo3dautoplugin.so
./opt/google/talkplugin/libnpgoogletalk64.so
./etc/cron.daily/google-talkplugin
./usr/lib/xulrunner/plugins/libnpgtpo3dautoplugin.so
./usr/lib/xulrunner/plugins/libnpgoogletalk64.so
./usr/lib/mozilla/plugins/libnpgtpo3dautoplugin.so
./usr/lib/mozilla/plugins/libnpgoogletalk64.so
./usr/lib/iceape/plugins/libnpgtpo3dautoplugin.so
./usr/lib/iceape/plugins/libnpgoogletalk64.so
./usr/lib/xulrunner-addons/plugins/libnpgtpo3dautoplugin.so
./usr/lib/xulrunner-addons/plugins/libnpgoogletalk64.so
./usr/lib/iceweasel/plugins/libnpgtpo3dautoplugin.so
./usr/lib/iceweasel/plugins/libnpgoogletalk64.so
./usr/lib/firefox/plugins/libnpgtpo3dautoplugin.so
./usr/lib/firefox/plugins/libnpgoogletalk64.so
./usr/lib/midbrowser/plugins/libnpgtpo3dautoplugin.so
./usr/lib/midbrowser/plugins/libnpgoogletalk64.so
-> Done extracting!
==> Moving files
-> Done moving files
==> Tidying install...
-> Purging other files...
-> Compressing man and info pages...
-> Stripping unneeded symbols from binaries and libraries...
==> Creating package...
-> Generating .PKGINFO file...
-> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: google-talkplugin 2.1.7.0-1 (Tue Jul 26 11:20:02 WIT 2011)
Password:
Password:
resolving dependencies...
looking for inter-conflicts...

Targets (1): google-talkplugin-2.1.7.0-1

Total Download Size:    0.00 MB
Total Installed Size:   24.88 MB

Proceed with installation? [Y/n] Y
(1/1) checking package integrity                   [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) installing google-talkplugin                 [######################] 100%
Optional dependencies for google-talkplugin
libnotify
pulseaudio
[go2n@chakra ~]$

Selesai! Sekarang tinggal hangout 😀

=-=-=-=-=
Powered by Blogilo

6 thoughts on “Hangout dengan Chakra

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s