KDE 4.6: kde4init Crash (Archlinux)

KDE 4.6 baru saja dirilis tanggal 26 Januari 2011 kemarin, dan saya baru saja meng-upgrade-nya melalui mirror http://mirrors.kernel.org/archlinux/ untuk mesin Archlinux saya. Setelah menunggu sekian lama akhirnya proses upgrade selesai. Namun upgrade KDE SC dari 4.5.5 ke 4.6 kali ini mengalami masalah, ketika login KDE KCMInit (kdeinit4) selalu crash dengan signal: Segmentation fault (11) dan hal ini menyebabkan proses io-slave pada KDE tidak dapat dijalankan.

Setelah browsing kesana kemari akhirnya dapat juga solusi pemecahan masalahnya untuk sementara. Yaitu dengan menjalankan kdeinit4 setelah login.

[me@archlinux ~]$ kdeinit4 &
[1] 12581
[me@archlinux ~]$ kdeinit4: Shutting down running client.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
KDE Daemon (kded) already running.
kbuildsycoca4 running...
kbuildsycoca4(12586) KConfigGroup::readXdgListEntry: List entry x-scheme-handler/file in "/home/me/.local/share/applications/mimeapps.list" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(12586) KConfigGroup::readXdgListEntry: List entry x-scheme-handler/trash in "/home/me/.local/share/applications/mimeapps.list" is not compliant with XDG standard (missing trailing semicolon).
....... (dst...)

Untuk solusi yang permanen (halah…) bisa dilakukan dengan cara mengupgrade soprano-2.5.3 ke soprano-2.5.63, namun ketika saya akan mengupgrade soprano ternyata paket tersebut tidak ada dalam repository. Hmm kacau juga nih jika setiap login KDE Desktop harus menjalankan kdeinit4. Akhirnya saya memilih untuk menginstall paket soprano-git via AUR untuk pemecahan masalah ini..

[me@archlinux ~]$ yaourt -S soprano-git
==> Downloading soprano-git PKGBUILD from AUR...
x PKGBUILD
First Submitted: Tue, 16 Nov 2010 07:28:29 +0000
soprano-git 20110112-1 : A library which provides a highly usable object-oriented C++/Qt4 framework for RDF data
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n
==> soprano-git dependencies:
- qt (already installed)
- clucene (already installed)
- redland (already installed)
- libiodbc (already installed)
- virtuoso (already installed)
- postgresql-libs (already installed)
- git (already installed)
- cmake (already installed)
==> Continue building soprano-git ? [Y/n]
==> -------------------------------------
==>
==> Building and installing package
==> Determining latest git revision...
-> Version found: 20110127
==> Making package: soprano-git 20110127-1 (Thu Jan 27 13:35:12 WIT 2011)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==> Extracting Sources...
==> Starting build()...
==> Connecting to the GIT server....
Cloning into soprano...
....... (dst...)

Setelah selesai install soprano-git, dan login kembali ke KDE Desktop pada akhirnya taadaaaaaa…. KDE Desktop 4.6 berjalan sebagaimana mestinya 😀

=-=-=-=-=
Powered by Blogilo

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s